PDFs show "Generic Download Failure Exception" / .json extension | VDRPro

  • Updated

Product: VDRPro
Applies to: All managers and publishers
 

Note: This article is intended for exchange managers and publishers. If you are an invited participant experiencing one of the issues outlined below, please contact an exchange manager to discuss the steps.

Otherwise, you can contact Intralinks Support. Click Submit a Ticket to open a request with our Support team. Or to speak directly with an agent, find our Support line in your region.

Issue

I'm trying to open an IRM Information Rights Management (IRM) provides security for downloaded documents. When IRM is applied, documents are encrypted before downloading, and users must enter their email address and password to view the documents. Exchange managers can revoke access at any time.-protected PDF file but see the following error or behavior:

  • Generic Download Failure Exception message
  • File downloads with .json extension / file type instead of .pdf

Possible causes

  • Corruption in the PDF file itself.
    • This issue within the file may conflict with the IRM security applied in the exchange.
  • PDF was created in a non-Adobe application. 
    • Intralinks IRM works best with PDFs created directly in Adobe Acrobat. In some cases, PDFs created in other applications won't open with IRM applied.
  • PDF version is unsupported.
    • Intralinks IRM supports PDF version 1.4 and above. If your file's version is 1.3 or earlier, it may cause an issue with the IRM protection.
    To check the PDF's producer or version, right-click in the body of the document and choose Document properties on the menu that appears. PDF Producer and PDF Version are displayed in the Advanced section.

Note: Users accessing a file without IRM protection might be able to open it, since the encryption conflict is not a factor in this case. If you are an exchange manager, you can temporarily add yourself to a group with IRM applied to see if you can replicate the issue.

Solution

Redistilling the PDF to create a new file and uploading the document to the exchange may resolve the issue.

Redistill the PDF with Adobe Acrobat Pro

  1. Open the PDF in Adobe Acrobat.
  2. Click File > Print
  3. In the printer drop-down menu, select Adobe PDF.  
  4. Click Print.  
  5. Select a folder location for the new file and click Save.  
    Note:  If you do not have Adobe Acrobat, open the file in your default PDF reader and use a print-to-PDF option in the print menu to recreate the file.

Print and scan to a new PDF

Another method for creating a new version of a PDF is simply to print the existing file and rescan it to a new PDF.

Password-encrypted PDFs

Intralinks IRM protection supports master passwords in PDF files (encryption required to change permissions in the file's properties). However, Intralinks IRM does not support PDFs that require a password to open the file. Such embedded encryption conflicts with the IRM protection and prevents the PDFs from opening.  

If your exchange has PDFs with embedded encryption that requires a password for opening the files, you must remove the encryption from the PDFs and upload new versions to the exchange.  If you prefer to use the embedded PDF security, be sure to only apply See permission in the exchange (without the Protected and No Print security). 

Remove embedded security from a PDF

  1. Open the PDF in Adobe Acrobat.
  2. Enter the password when prompted.
  3. Click File > Properties > Security.
  4. The Security Method field will display Password Security.
  5. Remove the password, then save the file or print it to a new PDF.
  6. Upload the new version to the exchange.
    Note: To remove password encryption, you must have the original password. If you do not, please contact the document author/creator for assistance. As an alternative, you can use the Print and scan to PDF method above to create a new PDF file.  

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