Product: VIA Pro for Android
Applies to: Owners, Editors and Viewers
Issue
I'm trying to open some files in the VIA app on my Android device, but I only see this message:
This file is protected. It should be opened using the Intralinks VIA web app.
Cause
The Intralinks VIA for Android app is unable to display IRM-protected files from Workspaces.
Note: Protected files are identified with a locked shield icon.
Solution
You have two possible options:
Use a computer (Recommended)
If possible, use a Windows or macOS computer to view the protected files.
- Log in to https://via.intralinks.com.
- Click the Workspace tile to access it.
- Next, either:
-
- Click the file name to view the file in the browser.
Note: Depending on the Workspace settings, in-browser viewing might be disabled. If this is the case, the file will automatically download to your computer.
- Hover your mouse cursor over the file pane and click the Download icon. Double-click the downloaded file to open it (and if you've already logged out of VIA, you'll be prompted to enter your Intralinks credentials to view the file).
Note: Adobe Reader DC is required to view downloaded PDFs; Microsoft Office is required for Word, Excel, and PowerPoint files.
- Click the file name to view the file in the browser.
Use a web browser on your Android device
Depending on the settings applied by the organization hosting the Workspace, this may or may not be an option.
You can try the steps below, with the following in mind:
- If the Workspace settings prevent files from opening in the browser, you'll see a different message still advising that you can't open the files.
- VIA Pro is not optimized for mobile browsers, so you'll need to drag the screen around to see the interface.
-
- Using Chrome, Firefox, or Microsoft Edge on your Android device, log in to https://via.intralinks.com.
- When prompted, be sure to tap Continue to website at the bottom of the next screen.
- Tap the Workspace tile to open it.
- Tap the file name to view the file in the browser.
- If the file instead downloads automatically, in-browser viewing is disabled on the Workspace. If this is the case, your only option is to use a computer to view the files.